<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-US" lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js">
	<head>
		<meta http-equiv="X-UA-Compatible" content="IE=8; IE=9" />
		<meta charset="utf-8">
		<meta name="robots" content="noodp">
		<link rel="canonical" href="https://machinelearning.apple.com/2017/12/06/learning-with-privacy-at-scale.html">
		<meta name="viewport" content="width=device-width, initial-scale=1" />
		<meta name="format-detection" content="telephone=no">
		<title>Learning with Privacy at Scale - Apple</title>
		<meta property="og:title" content="Learning with Privacy at Scale - Apple" />
		<meta property="og:description" content="Apple Machine Learning Journal publishes posts written by Apple engineers about their work using machine learning technologies to help build innovative products for millions of people around the world." />
		<meta property="og:url" content="https://machinelearning.apple.com/2017/12/06/learning-with-privacy-at-scale.html" />
		<meta property="og:image" content="https://www.apple.com/ac/structured-data/images/open_graph_logo.png" />
		<meta property="og:type" content="website" />
		<meta property="og:site_name" content="Apple Machine Learning Journal" />
		<meta property="og:locale" content="en_US" />
		<link rel="stylesheet" href="//www.apple.com/wss/fonts?families=SF+Pro,v1|SF+Pro+Icons,v1|SF+Mono,v1" type="text/css" media="all" />
		<link rel="stylesheet" href="/v/machine_learning_journals/a/built/styles/machine_learning_journals.built.css" />
		<script src="/v/machine_learning_journals/a/built/scripts/head.built.js" type="text/javascript" charset="utf-8"></script>
		<link rel="alternate" type="application/atom+xml" title="Apple Machine Learning Journal" href="/feed.xml" />
	</head>

			<body class="post">
		<nav class="localnav">
			<div class="ln-content">
				<h2 class="ln-title"><a class="img-ln-title-article" href="/">Machine Learning Journal</a></h2>
			</div>
		</nav>

		<main class="main" role="main">
			<section class="section section-journal" data-journal="true">
				<div class="section-content">
					<div class="large-8 large-centered medium-10 small-12">
						<div class="content-wrapper">
							<div class="content-block">
								<h1 class="typography typography-section-headline">
									
									Learning with Privacy at Scale
									
								</h1>
								<h2></h2>
								<p>
									 Vol. 1, Issue 8 <span class="weight-light" aria-hidden="true">∙</span> 
									<span aria-hidden="true">December 2017</span>
									<span class="visuallyhidden">December Two Thousand Seventeen
										  </span>
									<span class="line-break">by Differential Privacy Team</span>
								</p>
							</div>

							<hr>

							<div class="journal-content">
								
<p>Understanding how people use their devices often helps in improving the user experience. However, accessing the data that provides such insights — for example, what users type on their keyboards and the websites they visit — can compromise user privacy. We develop a system architecture that enables learning at scale by leveraging local differential privacy, combined with existing privacy best practices. We design efficient and scalable local differentially private algorithms and provide rigorous analyses to demonstrate the tradeoffs among utility, privacy, server computation, and device bandwidth. Understanding the balance among these factors leads us to a successful practical deployment using local differential privacy.  This deployment scales to hundreds of millions of users across a variety of use cases, such as identifying popular emojis, popular health data types, and media playback preferences in Safari. <!--more-->
We provide additional details about our system in the <a href="/docs/learning-with-privacy-at-scale/appledifferentialprivacysystem.pdf">full version</a>.</p>

<h1 id="introduction">Introduction</h1>

<p>Gaining insight into the overall user population is crucial to improving the user experience. The data needed to derive such insights is personal and sensitive, and must be kept private. In addition to privacy concerns, practical deployments of learning systems using this data must also consider resource overhead, computation costs, and communication costs. In this article, we give an overview of a system architecture that combines differential privacy and privacy best practices to learn from a user population.</p>

<p>Differential privacy <a href="#DMNS06">[2]</a> provides a mathematically rigorous definition of privacy and is one of the strongest guarantees of privacy available. It is rooted in the idea that carefully calibrated noise can mask a user’s data. When many people submit data, the noise that has been added averages out and meaningful information emerges.</p>

<p>Within the differential privacy framework, there are two settings: <em>central</em> and <em>local</em>.
In our system, we choose not to collect raw data on the server which is required for central differential privacy; hence, we adopt local differential privacy, which is a superior form of privacy <a href="#DR14">[3]</a>.
Local differential privacy has the advantage that the data is randomized before being sent from the device, so the server never sees or receives raw data.</p>

<p>Our system is designed to be opt-in and transparent. No data is recorded or transmitted before the user explicitly chooses to report usage information.
Data is privatized on the user’s device using event-level differential privacy <a href="#DNPR10">[4]</a> in the local model where an event might be, for example, a user typing an emoji. Additionally, we restrict the number of transmitted privatized events per use case.
The transmission to the server occurs over an encrypted channel once per day, with no device identifiers.
The records arrive on a restricted-access server where IP identifiers are immediately discarded, and any association between multiple records is also discarded. At this point, we cannot distinguish, for example, if an emoji record and a Safari web domain record came from the same user.
The records are processed to compute statistics. These aggregate statistics are then shared internally with the relevant teams at Apple.</p>

<p>We focus on the problem of estimating frequencies of elements — for example, emojis and web domains. In estimating frequencies of elements, we consider two subproblems.  In the first, we compute the histogram from a <em>known</em> dictionary of elements.  In the second, the dictionary is <em>unknown</em> and we want to obtain a list of the most frequent elements in a dataset.</p>

<h1 id="system-architecture">System Architecture</h1>

<p>Our system architecture consists of device-side and server-side data processing. On the device, the <em>privatization</em> stage ensures raw data is made differentially private. The restricted-access server does data processing that can be further divided into the <em>ingestion</em> and <em>aggregation</em> stages.
We explain each stage in detail below.</p>

<figure>
	<figcaption>Figure 1. System Overview.</figcaption>
	<a href="/images/journals/learning-with-privacy-at-scale/system_overview_large_2x.png" target="_blank">
		<img src="/images/journals/learning-with-privacy-at-scale/system_overview_large_2x.png" width="490px" alt="The overall system architecture consisting of device-side and server-side data processing." />
	</a>
</figure>

<h2 id="privatization">Privatization</h2>

<p>Users have the option, in System Preferences on macOS or in Settings on iOS, to share privatized records for analytics. For users who do not opt in, the system remains inactive. For users who do opt in, we define a per-event privacy parameter, <script type="math/tex">\epsilon.</script>
Additionally, we set a limit on the number of privatized records that can be transmitted daily for each use case.
Our choice of <script type="math/tex">\epsilon</script> is based on the privacy characteristics of the underlying dataset for each use case. These values are consistent with the parameters proposed in the differential privacy research community, such as <a href="#FPE16">[5]</a> and <a href="#QYYKX16">[6]</a>. Moreover, the algorithms we present below provide users further deniability due to hash collisions. We provide additional privacy by removing user identifiers and IP addresses at the server where the records are separated by use case so that there is no association between multiple records.</p>

<p>Whenever an event is generated on device, the data is immediately privatized via <script type="math/tex">\epsilon</script>-local differential privacy and temporarily stored on-device using data protection <a href="#AppleSecurity">[1]</a>, rather than being immediately transmitted to the server. After a delay based on device conditions,
the system randomly samples from the differentially private records subject to the above limit and sends the sampled records to the server.
These records do not include device identifiers or timestamps of when events were generated. The communication between a device and the server is encrypted using TLS. See Figure 2 for an overview.</p>

<figure>
	<figcaption>Figure 2. Privatization Stage.</figcaption>
	<a href="/images/journals/learning-with-privacy-at-scale/privatization_stage_large_2x.png" target="_blank">
		<img src="/images/journals/learning-with-privacy-at-scale/privatization_stage_large_2x.png" width="713px" alt="The on-device privatization stage in detail." />
	</a>
</figure>

<p>On iOS, the reports are visible in Settings <script type="math/tex">></script> Privacy <script type="math/tex">></script> Analytics <script type="math/tex">></script> Analytics Data in entries that begin with “DifferentialPrivacy.” On macOS, these records are visible in Console, in System Reports.
Figure 3 is a sample record of our algorithm for the Popular Emojis use case. The record lists algorithmic parameters, which are discussed in the section below, and the privatized data entry is represented as a hexadecimal string.  Note that the privatized data is elided here for presentation; the full size in this example is 128 bytes.</p>

<figure>
	<figcaption>Figure 3. Sample Report with Privatized Record.</figcaption>
	<a href="/images/journals/learning-with-privacy-at-scale/privatization_record_large_2x.png" target="_blank">
		<img src="/images/journals/learning-with-privacy-at-scale/privatization_record_large_2x.png" width="490px" alt="" />
   </a>
</figure>

<h2 id="ingestion-and-aggregation">Ingestion and Aggregation</h2>

<p>The privatized records are first stripped of their IP addresses prior to entering the ingestor. The ingestor then collects the data from all users and processes them in a batch. The batch process removes metadata, such as the timestamps of privatized records received, and separates these records based on their use case. The ingestor also randomly permutes the ordering of privatized records within each use case before forwarding the output to the next stage.</p>

<p>The aggregator takes the private records from the ingestor and for each use case generates a differentially private histogram according to the algorithms described in the section below. The data from multiple use cases is never combined when computing statistics. In these histograms, only domain elements whose counts are above a prescribed threshold <script type="math/tex">T</script> are included. These histograms are then shared internally with relevant teams at Apple.</p>

<h1 id="algorithms">Algorithms</h1>
<p>We now describe three local differentially private algorithms in the following sections.</p>

<h2 id="private-count-mean-sketch">Private Count Mean Sketch</h2>

<p>The Private Count Mean Sketch algorithm (CMS) aggregates records submitted by devices and outputs a histogram of counts over a dictionary of domain elements, while preserving local differential privacy.  This happens in two stages: client-side processing followed by server-side aggregation.</p>

<p>We illustrate the process with an example. Suppose a user visits the web domain <script type="math/tex">\textit{www.example.com}</script>. The client-side algorithm randomly samples a hash function from a set of candidate hash functions <script type="math/tex">\{h_1, h_2, h_3, \ldots , h_k \}</script> and encodes the web domain into a small space of size <script type="math/tex">m</script> using the selected hash function, say <script type="math/tex">h_2.</script>  Let <script type="math/tex">h_2(\textit{www.example.com})=31</script>. This encoding is written as a one-hot vector of size <script type="math/tex">m</script> where the bit at the <script type="math/tex">31</script>st position is set to <script type="math/tex">1</script>. To ensure differential privacy, each bit of the one-hot vector is independently flipped with probability <script type="math/tex">\frac{1}{e^{\epsilon/2} + 1}</script>, where <script type="math/tex">\epsilon</script> is the privacy parameter, which forms the privatized vector. This vector and the selected hash function index is then sent to the server.</p>

<p>The server-side algorithm constructs a <em>sketch matrix</em> <script type="math/tex">M</script> by aggregating the privatized vectors from the devices. The matrix has <script type="math/tex">k</script> rows — one for each hash function — and <script type="math/tex">m</script> columns corresponding to the size of the vector transmitted from the client.</p>

<p>As records arrive on the server, the algorithm adds the privatized vector to the vector at row <script type="math/tex">j</script>, where <script type="math/tex">j</script> is the index of the hash function sampled by the device. The values of <script type="math/tex">M</script> are then scaled appropriately so that each row helps provide an unbiased estimator for the frequency of each element.</p>

<p>To compute the frequency for a web domain <script type="math/tex">\textit{www.example.com}</script>, the algorithm takes each unbiased estimate by reading <script type="math/tex">M[j,h_j(\textit{www.example.com})]</script> for each row <script type="math/tex">j</script> and computes the mean of these estimates. In the full version of this article, we prove an analytic expression for the error (or variance) of the private counts, which allows us to have a principled approach in obtaining accurate counts while minimizing resource overhead like device bandwidth and server runtime in our deployment.</p>

<h2 id="private-hadamard-count-mean-sketch">Private Hadamard Count Mean Sketch</h2>

<p>We describe in the full version of this article how increasing the device bandwidth will lead to more accurate counts in CMS.  However, this leads to higher transmissions costs to users.  We wanted to have a minimal impact on accuracy while reducing transmission cost.  This led us to design the Private Hadamard Count Mean Sketch algorithm (HCMS), which has the advantage that the device can send one bit with a small loss in accuracy.  With HCMS, it is possible to achieve reasonably accurate counts without having users pay a high transmission cost.  We quantify the accuracy that we obtain with HCMS in the full version.</p>

<p>We now present HCMS with an example.  Suppose a user visits the web domain <script type="math/tex">\textit{www.example.com}</script>. As in CMS, the client-side algorithm selects a random hash function from a set of candidate hash functions <script type="math/tex">\{h_1, h_2, h_3, \ldots , h_k \}</script> and encodes the web domain into a small space using the selected hash function, say <script type="math/tex">h_3</script>. Let <script type="math/tex">h_3(\textit{www.example.com})=42</script>. This encoding is written as a one-hot vector <script type="math/tex">\bf{v}</script> <script type="math/tex">= (0,0,\ldots , 0, 1 ,0,  \ldots, 0, 0)</script> where the <script type="math/tex">1</script> is at position <script type="math/tex">42</script>. Since we want to transmit a single bit, a trivial approach would be to sample and send a random coordinate from <script type="math/tex">\bf{v}</script>. However, this increases the error (variance) in the resulting histogram significantly. To help reduce the variance, we use the Hadamard basis transform <script type="math/tex">H</script> on <script type="math/tex">\bf{v}</script> to obtain <script type="math/tex">\bf{v}'</script> <script type="math/tex">= H\bf{v}</script> <script type="math/tex">= (+1, -1, \ldots , +1)</script>, for instance. A single random coordinate is sampled from <script type="math/tex">\bf{v}'</script>, and the corresponding bit is flipped with probability <script type="math/tex">\frac{1}{e^{\epsilon} + 1}</script>, to ensure differential privacy.  The output sent to the server includes the index of the selected hash function, the sampled coordinate index and the privatized bit; see Figure 4.</p>

<figure>
	<figcaption>Figure 4. Client-Side Algorithm for Hadamard Count Mean Sketch.</figcaption>
	<a href="/images/journals/learning-with-privacy-at-scale/hcms_client_large_2x.png" target="_blank">
		<img src="/images/journals/learning-with-privacy-at-scale/hcms_client_large_2x.png" width="490px" alt="The steps in the client-side algorithm for Hadamard Count Mean Sketch." />
	</a>
</figure>

<p>Similar to CMS, the server-side algorithm uses a data structure, <em>sketch matrix</em> <script type="math/tex">M</script> to aggregate the privatized vectors from the clients. The rows of the matrix <script type="math/tex">M</script> are indexed by the candidate hash functions. Additionally, the columns are indexed by the random coordinate indices that the device samples. The <script type="math/tex">(j,l)</script>th cell of the matrix aggregates the privatized vectors submitted by devices that chose the <script type="math/tex">j</script>th hash function <script type="math/tex">h_j</script> and sampled the <script type="math/tex">l</script>th coordinate from the vector.  Further, privatized vectors are scaled appropriately and <script type="math/tex">M</script> is transformed back to the original basis using the inverse Hadamard matrix. At this stage, each row of the matrix helps provide an unbiased estimator for the frequency of an element. To compute the frequency for a web domain <script type="math/tex">\textit{www.example.com}</script>, the algorithm first obtains an estimate from each row of <script type="math/tex">M</script> by reading <script type="math/tex">M[j,h_j(\textit{www.example.com})]</script> from row <script type="math/tex">j</script>. As a final step, the algorithm computes the mean of these <script type="math/tex">k</script> estimates to reduce variance; see Figure 5.</p>

<figure>
	<figcaption>Figure 5. Server-Side Algorithm for Hadamard Count Mean Sketch.</figcaption>
	<a href="/images/journals/learning-with-privacy-at-scale/hcms_server_large_2x.png" target="_blank">
		<img src="/images/journals/learning-with-privacy-at-scale/hcms_server_large_2x.png" width="490px" alt="The steps in the server-side algorithm for Hadamard Count Mean Sketch." />
	</a>
</figure>

<h2 id="private-sequence-fragment-puzzle">Private Sequence Fragment Puzzle</h2>

<p>The previous algorithms assume there is some known dictionary of domain elements through which the server can enumerate in order to determine the corresponding counts. However,
in certain use cases, the domain is massive and enumerating over the full space is computationally prohibitive. For example, in discovering frequently typed new words, even if we restrict ourselves to 10-letter case-sensitive English words, this approach would require the server to loop over at least <script type="math/tex">52^{10}</script> elements.</p>

<p>Instead, we develop an algorithm called Sequence Fragment Puzzle (SFP) and present it in the setting of discovering new words. We take advantage of the fact that given a popular string, any substring of that string is also at least as popular. On the device, we use the client-side CMS algorithm to privatize the typed word. Additionally, we select a substring of the word and concatenate it with an 8-bit hash of the word. We refer to the small hash as the <em>puzzle piece</em> and the substring concatenated with the hash as the <em>fragment</em>. The fragment is privatized using CMS and also transmitted to the server along with the privatized word. For example, if the word is <script type="math/tex">\textit{Despacito}</script> and the selected substring is <script type="math/tex">\textit{sp}</script>, the client sends three things: CMS<script type="math/tex">(\textit{Despacito}),</script> CMS<script type="math/tex">(\textit{sp}\|97)</script> where <script type="math/tex">97</script> is the puzzle piece, and the location of the selected substring.</p>

<p>Using sketches for fragments, the server-side algorithm obtains a histogram over all possible fragments for each substring location. The puzzle piece allows the server to correlate fragments from the same word since all fragments from a word will have the same puzzle piece. Then, restricting itself to the most popular fragments, the server algorithm determines a list of candidate strings by concatenating popular fragments whose puzzle pieces match.
The set of candidate strings forms a dictionary of reasonable size and lets us use the CMS algorithm on the full word.</p>

<h1 id="results">Results</h1>

<p>We present three use cases below to illustrate how our algorithms are used to enhance product features while protecting user privacy.</p>

<h2 id="discovering-popular-emojis">Discovering Popular Emojis</h2>

<p>Given the popularity of emojis across our user base, we want to determine which specific emojis are most used by our customers and the relative distribution of these characters.  To that end, we deploy our algorithms to understand the distribution of emojis used across keyboard locales. For this use case, we set the parameters for CMS to be <script type="math/tex">m</script> = 1024, <script type="math/tex">k</script> = 65,536, and <script type="math/tex">\epsilon</script> = 4 with dictionary size of 2600 emojis.</p>

<p>The data shows many differences across keyboard locales. In Figure 6, we observe snapshots from two locales: English and French.  Using this data, we can improve our predictive emoji QuickType across locales.</p>

<figure>
	<figcaption>Figure 6. Emojis in Different Keyboard Locales.</figcaption>
	<a href="/images/journals/learning-with-privacy-at-scale/emojitogether_large_2x.png" target="_blank">
		<img src="/images/journals/learning-with-privacy-at-scale/emojitogether_large_2x.png" width="490px" alt="Popular emojis in two different keyboard locales: English and French." />
	</a>
</figure>

<h2 id="identifying-high-energy-and-memory-usage-in-safari">Identifying High Energy and Memory Usage in Safari</h2>

<p>Some websites are exceedingly resource-intensive, and we wish to identify these sites in order to ensure a better user experience. We consider two types of domains: those that cause high memory usage and those that cause excessive energy drain from CPU usage. In iOS 11 and macOS High Sierra, Safari can automatically detect these exceptional domains and report them using differential privacy.</p>

<p>Using our algorithms, we are able to determine which domains have high resource consumption.
For this use case, we set the parameters for HCMS to be <script type="math/tex">m</script> = 32,768, <script type="math/tex">k</script> = 1024, and <script type="math/tex">\epsilon</script> = 4 with dictionary size of 250,000 web domains.
Recall that the differentially private record is only a single bit in HCMS.
Our data shows that the most common, high-resource domains include video consumption websites, shopping websites, and news websites.</p>

<h2 id="discovering-new-words">Discovering New Words</h2>

<p>We want to learn words that are not present in the lexicons included on the device in order to improve auto-correction. To discover new words, we deploy the Sequence Fragment Puzzle (SFP) algorithm described above.</p>

<p>The algorithm produces results spanning several languages, including English, French, and Spanish. The learned words for the English keyboard, for example, can be divided into multiple categories: abbreviations like <em>wyd</em>, <em>wbu</em>, <em>idc</em>; popular expressions like <em>bruh</em>, <em>hun</em>, <em>bae</em>, and <em>tryna</em>, seasonal or trending words like <em>Mayweather</em>, <em>McGregor</em>, <em>Despacito</em>, <em>Moana</em>, and <em>Leia</em>;  and foreign words like <em>dia</em>, <em>queso</em>, <em>aqui</em>, and <em>jai</em>. Using the data, we are constantly updating our on-device lexicons to improve the keyboard experience.</p>

<p>Another category of words discovered are known words without the trailing <em>e</em> (<em>lov</em> or <em>th</em>) or <em>w</em> (<em>kno</em>). If users accidentally press the left-most prediction cell above the keyboard, which contains the literal string typed thus far, a space will be added to their current word instead of the character they intended to type.  This is a key insight that we were able to learn due to our local differentially private algorithm.</p>

<h1 id="conclusion">Conclusion</h1>
<p>In this article, we have presented a novel learning system architecture, which leverages local differential privacy and combines it with privacy best practices. To scale our system to millions of users and a variety of use cases, we have developed novel local differentially private algorithms – CMS, HCMS, and SFP – for both the known and unknown dictionary settings. In our <a href="/docs/learning-with-privacy-at-scale/appledifferentialprivacysystem.pdf">full paper</a>, we have provided analytic expressions for the tradeoffs among various factors, including privacy, utility, server computation overhead, and device bandwidth.  Our utility theorems give a principled way to choose algorithmic parameters to minimize the transmission cost for the users without lowering accuracy. Without such expressions, it is difficult to evaluate the impact on accuracy if, for example, transmission cost is reduced without running costly iterations. Further, to keep transmission costs to an absolute minimum, our HCMS algorithm can obtain accurate counts when each user sends only a single privatized bit. We believe that our paper is one of the first to demonstrate the successful deployment of local differential privacy, <a href="#EPK14">[7]</a>, in a real-world setting across multiple use cases. We have shown that we could find popular abbreviations and slang words typed, popular emojis, popular health data types while satisfying local differential privacy. Further, we can identify websites that are consuming too much energy and memory, and websites where users want Auto-play.  This information has been used to improve features for the benefit of the user experience.</p>

<p>We hope that our work will serve a role in bridging the gap between theory and practice of private systems. We also believe our work will continue to support research in a broad set of large-scale learning problems while preserving users’ privacy.</p>

<h1 id="references">References</h1>

<p><a name="AppleSecurity">[1]</a> <a href="https://www.apple.com/business/docs/iOS_Security_Guide.pdf"><em>https://www.apple.com/business/<wbr />docs/<wbr />iOS_Security_Guide.pdf</em><a>.</a></a></p>

<p><a name="DMNS06">[2]</a> C. Dwork, F. McSherry, K. Nissim, and A. Smith. <strong>Calibrating Noise to Sensitivity in Private Data Analysis</strong>. <em>TCC<em>, 2006.</em></em></p>

<p><a name="DR14">[3]</a> C. Dwork and A. Roth. <strong>The Algorithmic Foundations of Differential Privacy</strong>. <em>Foundations and Trends in Theoretical Computer Science<em>, 2014.</em></em></p>

<p><a name="DNPR10">[4]</a> C. Dwork, M. Naor, T. Pitassi, and G. N. Rothblum. <strong>Differential Privacy Under Continual Observation</strong>. <em>Proceedings of the Forty-second ACM Symposium on Theory of Computing<em>, 2010.</em></em></p>

<p><a name="FPE16">[5]</a> G. Fanti, V. Pihur, and Ú. Erlingsson. <strong>Building a RAPPOR with the Unknown: Privacy-Preserving Learning of Associations and Data Dictionaries</strong>. <em>PoPETS<em>, 2016.</em></em></p>

<p><a name="QYYKX16">[6]</a> Z. Qin, Y. Yang, T. Yu, I. Khalil, X. Xiao, and K. Ren. <strong>Heavy Hitter Estimation Over Set-valued Data with Local Differential Privacy</strong>. <em>Proceedings of the 2016 ACM SIGSAC Conference on Computer and Communications Security<em>, 2016.</em></em></p>

<p><a name="EPK14">[7]</a> Ú. Erlingsson, V. Pihur, and A. Korolova. <strong>RAPPOR: Randomized Aggregatable Privacy-Preserving Ordinal Response</strong>. <em>Proceedings of the 21st ACM Conference on Computer and Communications Security<em>, 2014.</em></em></p>

							</div>
						</div>
					</div>
				</div>
			</section>

			<section class="section section-prefooter theme-dark">
	<div class="section-content">
		<div class="row">
			<div class="column large-4 medium-12">
				<div class="text-center">
					<h2 class="prefooter-title">Contact us</h2>
					<p><a href="mailto:machine-learning@apple.com">Send questions or feedback<span class="visuallyhidden"> via email</span><span class="more"></span></a></p>
				</div>
			</div>
			<div class="column large-4 medium-12">
				<div class="text-center">
					<h2 class="prefooter-title">Jobs at Apple</h2>
					<p><a href="https://www.apple.com/jobs/">Apply now<span class="visuallyhidden"> for a career at Apple</span><span class="more"></span></a></p>
				</div>
			</div>
			<div class="column large-4 medium-12">
				<div class="text-center">
					<h2 class="prefooter-title">Tools for innovation</h2>
					<p><a href="https://developer.apple.com/">Apple Developer Program<span class="more"></span></a></p>
				</div>
			</div>
		</div>
	</div>
</section>
		</main>

		<footer class="section section-footer" role="contentinfo">
			<div class="section-content">
				<div class="row">
					<div class="column large-6 small-12">
						<div class="footer-left">
							<a class="logo" href="https://www.apple.com/"></a>
							<span class="copyright typography-caption" aria-hidden="true">Copyright © 2017 Apple Inc. All rights reserved.</span>
							<span class="visuallyhidden">Copyright two thousand seventeen Apple Inc. All rights reserved.</span>
						</div>
					</div>
					<div class="column large-6 small-12">
						<div class="footer-right">
							<a class="typography-caption" href="/feed.xml">Subscribe</a>
							<a class="typography-caption" href="//www.apple.com/privacy/privacy-policy/">Privacy Policy</a>
							<a class="typography-caption" href="//www.apple.com/legal/internet-services/terms/site.html">Terms of Use</a>
							<a class="typography-caption" href="//www.apple.com/legal/">Legal</a>
						</div>
					</div>
				</div>
			</div>
		</footer>
		<script src="/v/machine_learning_journals/a/built/scripts/main.built.js" type="text/javascript" charset="utf-8"></script>
	</body>
</html>
