<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-US" lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js">
	<head>
		<meta http-equiv="X-UA-Compatible" content="IE=8; IE=9" />
		<meta charset="utf-8">
		<meta name="robots" content="noodp">
		<link rel="canonical" href="https://machinelearning.apple.com/2018/12/03/optimizing-siri-on-homepod-in-far-field-settings.html">
		<meta name="viewport" content="width=device-width, initial-scale=1" />
		<meta name="format-detection" content="telephone=no">
		<title>Optimizing Siri on HomePod in Far‑Field Settings - Apple</title>
		<meta property="og:title" content="Optimizing Siri on HomePod in Far‑Field Settings - Apple" />
		<meta property="og:description" content="Apple Machine Learning Journal publishes posts written by Apple engineers about their work using machine learning technologies to help build innovative products for millions of people around the world." />
		<meta property="og:url" content="https://machinelearning.apple.com/2018/12/03/optimizing-siri-on-homepod-in-far-field-settings.html" />
		<meta property="og:image" content="https://www.apple.com/ac/structured-data/images/open_graph_logo.png" />
		<meta property="og:type" content="website" />
		<meta property="og:site_name" content="Apple Machine Learning Journal" />
		<meta property="og:locale" content="en_US" />
		<link rel="stylesheet" href="//www.apple.com/wss/fonts?families=SF+Pro,v2|SF+Pro+Icons,v1|SF+Mono,v1" type="text/css" media="all" />
		<link rel="stylesheet" href="/v/machine_learning_journals/a/built/styles/machine_learning_journals.built.css" />
		<script src="/v/machine_learning_journals/a/built/scripts/head.built.js" type="text/javascript" charset="utf-8"></script>
		<link rel="alternate" type="application/atom+xml" title="Apple Machine Learning Journal" href="/feed.xml" />
	</head>

			<body class="post">
		<!-- metrics: place just after <body> -->
<script>
    /* RSID: */
    var s_account="awdmachinelearning"
</script>
<script src="https://developer.apple.com/assets/metrics/scripts/analytics.js"></script>
<script>
  if (location.href.startsWith('https://machinelearning.apple.com')) {
    s.pageName= AC && AC.Tracking && AC.Tracking.pageName();

    /************* DO NOT ALTER THE NEXT LINE ! **************/
    var s_code=s.t();if(s_code)document.write(s_code)
  }
</script>
<!-- /metrics -->

		<nav class="localnav">
			<div class="ln-content">
				<h2 class="ln-title"><a class="img-ln-title-article" href="/">Machine Learning Journal</a></h2>
			</div>
		</nav>

		<main class="main" role="main">
			<section class="section section-journal" data-journal="true">
				<div class="section-content">
					<div class="large-8 large-centered medium-10 small-12">
						<div class="content-wrapper">
							<div class="content-block">
								<h1 class="typography typography-section-headline">
									
									Optimizing Siri on HomePod in Far‑Field Settings
									
								</h1>
								<h2></h2>
								<p>
									 Vol. 1, Issue 12 <span class="weight-light" aria-hidden="true">∙</span> 
									<span aria-hidden="true">December 2018</span>
									<span class="visuallyhidden">December Two Thousand Eighteen
										  </span>
									<span class="line-break">by Audio Software Engineering and Siri Speech Team</span>
								</p>
							</div>

							<hr>

							<div class="journal-content">
								

<p>The typical audio environment for HomePod has many challenges — echo, reverberation, and noise.  Unlike Siri on iPhone, which operates close to the user’s mouth, Siri on HomePod must work well in a far-field setting. Users want to invoke Siri from many locations, like the couch or the kitchen, without regard to where HomePod sits. A complete online system, which addresses all of the environmental issues that HomePod can experience, requires a tight integration of various multichannel signal processing technologies. Accordingly, the Audio Software Engineering and Siri Speech teams built a system that integrates both supervised deep learning models and unsupervised online learning algorithms and that leverages multiple microphone signals. The system selects the optimal audio stream for the speech recognizer by using top-down knowledge from the “Hey Siri” trigger phrase detectors. In this article, we discuss the machine learning techniques we use for online signal processing, as well as the challenges we faced and our solutions for achieving environmental and algorithmic robustness while ensuring <a href="https://www.apple.com/environment/pdf/products/homepod/HomePod_PER_jan2018.pdf">energy efficiency</a>.
<!--more--></p>

<h1 id="introduction">Introduction</h1>

<p>HomePod is a home speaker with smart home capabilities including far-field Siri, which the user can control through speech even while music is playing. Siri on HomePod is designed to work in challenging usage scenarios such as:</p>

<ul>
  <li>During loud music playback</li>
  <li>When the talker is far away from HomePod</li>
  <li>When other sound sources in a room, such as a TV or household appliances, are active</li>
</ul>

<p>Under all these conditions, Siri on HomePod should respond and correctly recognize commands.</p>

<p>This article describes HomePod’s multichannel signal processing system with emphasis on these approaches:</p>

<ul>
  <li>Mask-based multichannel filtering using deep learning to remove echo and background noise</li>
  <li>Unsupervised learning to separate simultaneous sound sources and trigger-phrase based stream selection to eliminate interfering speech</li>
</ul>

<p>The system uses six microphones and runs the multichannel signal processing continuously on an Apple A8 chip, including when the Homepod is run in its lowest power state to save energy.  The multichannel filtering constantly adapts to changing noise conditions and moving talkers.</p>

<p>Other state-of-the-art systems use multi-microphone processing to enhance speech, but typically focus only on a subset of problems such as dereverberation [<a href="#1">1</a>] and noise suppression [<a href="#2">2</a>]. To suppress the undesired signal components, a speech enhancement system must learn the desired and undesired signal characteristics using supervised or unsupervised learning methods.  Recently, speech enhancement performance has improved substantially due to deep learning. In [<a href="#2">2</a>], for example, the top performing techniques learn the speech presence probability using a deep neural network (DNN), which drives multichannel noise suppression filters. However, these systems are commonly built assuming that the full speech utterance is available during runtime and that the system performs batch processing to take advantage of all speech samples during the voice command [<a href="#3">3</a>]. This setup increases latency and precludes speech enhancement for always-listening modes on home assistant devices, including trigger phrase detection and endpointing functionalities. The assumptions behind batch speech enhancement systems are unrealistic for HomePod because the acoustic conditions are unpredictable, and the start and end points of the voice commands aren’t available beforehand.</p>

<p>Far-field speech recognition becomes more challenging when another active talker, like a person or a TV, is present in the same room with the target talker. In this scenario, voice trigger detection, speech decoding, and endpointing can be substantially degraded if the voice command isn’t separated from the interfering speech components. Traditionally, researchers tackle speech source separation using either unsupervised methods, like independent component analysis and clustering [<a href="#4">4</a>], or deep learning [<a href="#5">5</a>, <a href="#6">6</a>]. These techniques can improve automatic speech recognition in conferencing applications or on batches of synthetic speech mixtures where each speech signal is extracted and transcribed [<a href="#6">6</a>, <a href="#7">7</a>]. Unfortunately, the usability of these batch techniques in far-field voice command-driven interfaces is very limited. Furthermore, the effect of source separation on voice trigger detection, such as that used with “Hey Siri”, has never been investigated previously. Finally, it’s crucial to separate far-field mixtures of competing signals online to avoid latencies and to select and decode only the target stream containing the voice command.</p>

<h1 id="siri-on-homepod-signal-model-and-speech-enhancement-system-overview">Siri on HomePod: Signal Model and Speech Enhancement System Overview</h1>

<p>The multichannel far-field signal model can be written in the frequency domain as:</p>

<div class="mathEl text-center">
<math xmlns="http://www.w3.org/1998/Math/MathML" display="block"><mrow><msub><mrow>
        <mi mathvariant="bold">y</mi></mrow><mrow><mi>k</mi></mrow></msub><mrow><mo class="MathClass-open">[</mo><mrow><mi>n</mi></mrow><mo class="MathClass-close">]</mo></mrow> <mo class="MathClass-rel">=</mo><munderover accentunder="false" accent="false"><mrow><mo mathsize="big"> ∑</mo>
  </mrow><mrow><mi>l</mi><mo class="MathClass-rel">=</mo><mn>1</mn></mrow><mrow><msub><mrow><mi>N</mi></mrow><mrow><mi>x</mi></mrow></msub>
         </mrow></munderover><msub><mrow><mi mathvariant="bold">H</mi></mrow><mrow><mi>k</mi></mrow></msub><mrow><mo class="MathClass-open">[</mo><mrow><mi>l</mi></mrow><mo class="MathClass-close">]</mo></mrow><msub><mrow><mi mathvariant="bold">x</mi></mrow><mrow><mi>k</mi></mrow></msub><mrow><mo class="MathClass-open">[</mo><mrow><mi>n</mi> <mo class="MathClass-bin">−</mo> <mi>l</mi></mrow><mo class="MathClass-close">]</mo></mrow> <mo class="MathClass-bin">+</mo><munderover accentunder="false" accent="false"><mrow><mo mathsize="big"> ∑</mo>
  </mrow><mrow><mi>p</mi><mo class="MathClass-rel">=</mo><mn>1</mn></mrow><mrow><msub><mrow><mi>N</mi></mrow><mrow><mi>s</mi></mrow></msub>
         </mrow></munderover><msub><mrow><mi mathvariant="bold">G</mi></mrow><mrow><mi>k</mi></mrow></msub><mrow><mo class="MathClass-open">[</mo><mrow><mi>p</mi></mrow><mo class="MathClass-close">]</mo></mrow><msub><mrow><mi mathvariant="bold">s</mi></mrow><mrow><mi>k</mi></mrow></msub><mrow><mo class="MathClass-open">[</mo><mrow><mi>n</mi> <mo class="MathClass-bin">−</mo> <mi>p</mi></mrow><mo class="MathClass-close">]</mo></mrow> <mo class="MathClass-bin">+</mo><msub><mrow> <mi mathvariant="bold">v</mi></mrow><mrow><mi>k</mi></mrow></msub><mrow><mo class="MathClass-open">[</mo><mrow><mi>n</mi></mrow><mo class="MathClass-close">]</mo></mrow>
</mrow></math>
</div>

<p>where:</p>
<ul>
  <li><em>n</em> is the time index</li>
  <li><em>k</em> is the frequency index</li>
  <li><em>l</em>,<em>p</em> are the impulse response time indices</li>
  <li><em>y<sub>k</sub></em> are the <em>M</em> are the  microphone signals containing echo, reverberation, noise, and competing talkers</li>
  <li><em>x<sub>k</sub></em> are the <em>N<sub>x</sub></em> channels of playback signals</li>
  <li><em>s<sub>k</sub></em> are the <em>N<sub>s</sub></em> speech sources</li>
  <li><em>v<sub>k</sub></em> are the background noise components captured by <em>M</em></li>
  <li><em>H<sub>k</sub></em> are the multichannel impulse responses from the loudspeakers to the microphones, a total of <em>MN<sub>x</sub></em> responses</li>
  <li><em>G<sub>k</sub></em> are the multichannel impulse responses from speech sources to the microphones, a total of <em>MN<sub>s</sub></em> responses</li>
</ul>

<p>The aim of the multichannel signal processing system is to extract one of the speech sources in <strong>s</strong><script type="math/tex">_k</script> by removing echo, reverberation, noise, and competing talkers to improve intelligibility. Figure 1 shows an overview of our system.</p>

<figure role="presentation">
    <a href="/images/journals/homepod-siri-wild/figure_1_2x.png" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_1_2x.png" width="550px" alt="" />
    </a>
    <figcaption>Figure 1. Block diagram of the online multichannel signal processing chain on HomePod for Siri.</figcaption>
</figure>

<h1 id="multichannel-echo-cancellation">Multichannel Echo Cancellation</h1>

<p>Due to the close proximity of the loudspeakers to the microphones on HomePod, the playback signal can be significantly louder than a user’s voice command at the microphone positions, especially when the user moves away from the device. In fact, the echo signals may be 30-40 dB louder than the far-field speech signals, resulting in the trigger phrase being undetectable on the microphones during loud music playback. Siri on HomePod implements the Multichannel Echo Cancellation (MCEC) algorithm, which uses a set of linear adaptive filters to model the multiple acoustic paths between the loudspeakers and the microphones to cancel the acoustic coupling.  Two problems limit the MCEC from completely removing the device’s own playback signal from the microphones in practice:</p>

<ul>
  <li>Nonlinear coupling. Due to loudspeaker nonlinearity and mechanical vibrations of the devices, the entirety of the playback signal isn’t captured by the linear system model [<a href="#8">8</a>].</li>
  <li>Non-unique solutions. When multichannel content is playing from the beamforming speaker array, the solution can be non-unique [<a href="#9">9</a>].</li>
</ul>

<p>Therefore, a residual echo suppressor (RES) is required to remove remaining playback content after the MCEC.  We discuss our deep learning approach to residual echo suppression in the next section.</p>

<h1 id="mask-based-echo-suppression">Mask-Based Echo Suppression</h1>

<p>At loud playback volumes, the MCEC usually provides insufficient echo cancellation for successful trigger phrase detection, resulting in residual echo levels which are 10 to 20 dB above the far-field speech. The RES is designed to suppress nonlinear components of the echo signal that aren’t being modeled by the linear MCEC. The RES also mitigates residual linear echo, especially in the presence of double-talk and echo path changes.</p>

<p>Typical data-driven residual echo suppression approaches [<a href="#10">10</a>, <a href="#11">11</a>] extract input features from reference and echo-canceled signals, and use the network to apply suppression gains directly to the echo-canceled signal. In our approach to RES, a DNN takes in multiple input features and outputs an estimate of a speech activity mask that is used as an input Speech Presence Probability (SPP) for a Multichannel Wiener Filter (MCWF). The input features are extracted from the echo-canceled signals along with the linear echo estimate provided by the MCEC.</p>

<p>The mask-based echo suppression approach has several benefits:</p>

<ul>
  <li>Because we trained the deep neural network on actual echo recordings, it learns to suppress residual echo signals arising from loudspeaker nonlinearities and mechanical vibrations specific to HomePod. These distortions aren’t easy to track and suppress using traditional statistical approaches.</li>
  <li>The SPP predicted by the DNN drives the MCWF to steer directional nulls that significantly reduce the residual echo while introducing low speech distortion.</li>
  <li>We also used the SPP to drive a single-channel suppression gain on the output of the MCWF to further suppress the residual echo that isn’t removed by the MCWF.</li>
</ul>

<h1 id="reverberation-removal">Reverberation Removal</h1>

<p>As a speech source moves further away from the microphones, multiple reflections from the room create reverberation tails that decrease the quality and intelligibility of the target speech. The signal captured by a microphone can be characterized by the direct sound (speech without any reflection), the early reflections, and the late reverberation. The late reverberation can severely degrade speech recognizer performance [<a href="#12">12</a>, <a href="#13">13</a>]. Siri on HomePod continuously monitors the room characteristics and removes the late reverberation while preserving the direct and early reflection components in the microphone signals.</p>

<h1 id="mask-based-noise-reduction">Mask-Based Noise Reduction</h1>

<p>In addition to reverberation, far-field speech is typically contaminated by noise from home appliances, HVAC, outdoor sounds entering through windows, and various other noise sources. Mask-based MCWF is a powerful tool for noise-robust far-field speech recognition in batch conditions [<a href="#3">3</a>,<a href="#14">14<a></a>]. Unlike traditional single-channel approaches, the MCWF is a signal-dependent beamformer that can steer nulls toward spatially localized noise sources without distorting the target speech. This capability is possible when the SPP is estimated correctly, using either statistical models [<a href="#14">14</a>,<a href="#15">15</a>] or learned by DNNs [<a href="#3">3</a>].  When processed in batch, this approach assumes that noise and speech sources aren’t moving during the active speech segments.</a></p>

<p>These state-of-the-art speech enhancement methods create a fixed filter for each utterance using all of the aggregate estimations of speech and noise to enhance the speech before feeding it to the recognizer.  A DNN trained to recognize the spectral characteristics of speech and noise can reduce noise even more for this problem of mask estimation. However, to deal with the constantly changing acoustic environment, we require an online noise reduction system that can track environmental noise with low latency. We built an online MCWF that estimates speech and noise statistics using only the current and past microphone signals. In addition, we deployed a DNN that predicts the SPP and drives the MCWF to steer directional nulls toward interfering noise sources.</p>

<p>We trained the DNN on internally collected data using both diffuse and directional noises, as well as continuous and discrete noises that are difficult to model statistically. We synthetically mixed near-end speech-only recordings and noise-only recordings to produce speech-plus-noise recordings. This mix allows us to generate ground truth (oracle) targets for the SPP. We calculated the input features to the DNN from the dereverberated signal and the reverberation estimate.  The output features are the speech activity mask calculated from the near-end speech and the speech-plus-noise mixture.</p>

<h1 id="unsupervised-learning-with-top-down-knowledge-to-mitigate-competing-speech">Unsupervised Learning with Top-Down Knowledge to Mitigate Competing Speech</h1>

<p>The corruption of target speech by other interfering talkers is challenging for both speech enhancement and recognition. Blind source separation (BSS) is a technique that can simultaneously separate multiple audio  sources into individual audio streams in an unsupervised fashion [<a href="#4">4</a>].  However,  selecting the correct audio stream from the multiple output streams remains a challenge and requires top-down knowledge of a user’s voice command.  In addition to using the trigger phrase “Hey Siri” as a strong acoustic cue to identify the target stream, we developed a competing talker separation approach and a deep learning stream selection system.</p>

<h1 id="competing-talker-separation">Competing Talker Separation</h1>

<p>We deployed a computationally lightweight unsupervised learning method for blind source separation to decompose the microphone array signals into independent audio streams.  The method used leverages the statistical property of independence between the competing sources and the correlation of the spectral components of each source and is numerically stable and fast‐converging. Our BSS algorithm learns the acoustic channel at every new input audio frame directly from the microphone signals, and separates the competing sources with a computational complexity of <script type="math/tex">\mathcal{O}(M^2)</script> per source at a given sub-band. It outputs <script type="math/tex">N_s</script> streams given <script type="math/tex">M</script> input channels.  Although the algorithm doesn’t suffer from the frequency permutation ambiguity known in other traditional approaches such as independent component analysis, the arrangement of the output sources can’t be known ahead of time. Additional prior knowledge is then needed to identify the target stream.</p>

<h1 id="deep-learningbased-stream-selection">Deep Learning–Based Stream Selection</h1>

<p>The noise-plus-residual-echo suppression and source separation algorithms play complementary roles in the proposed system. They jointly learn the acoustic environment and address the diverse conditions in which HomePod can be used, for example, quiet environment, noisy background, loud playback, and competing talker. Because prior information on the acoustic scene of interest is difficult to obtain during runtime, and because the arrangement of the <script type="math/tex">N_s</script> output streams of BSS is arbitrary, we developed a deep learning–based stream selection system to determine the best audio stream using the voice trigger. Our system essentially leverages the on-device DNN-powered “Hey Siri” detector described in [<a href="#16">16</a>], and continuously monitors the <script type="math/tex">N_s+1</script> audio streams. When “Hey Siri” is detected, each stream is assigned a goodness score. The stream with the highest score is selected and sent to Siri for speech recognition and task completion.</p>

<p>Figure 2 depicts examples of trigger scores computed during “Hey Siri” for mask-based noise reduction in blue and the best BSS stream in green. The left plot shows data obtained in a relatively quiet acoustic condition.  You can see that mask-based noise reduction is optimal. The data shown in the right plot is from a more challenging acoustic condition — a speech signal corrupted by a loud television playing nearby.  The BSS stream has a large score and should be selected over mask-based noise reduction.</p>

<figure role="presentation">
    <a href="/images/journals/homepod-siri-wild/figure_2_2x.png" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_2_2x.png" width="665px" alt="" />
    </a>
    <figcaption>Figure 2. Voice trigger score vs. time: (left) Siri voice command recorded in low level music playback on HomePod, (right) Siri voice command recorded on HomePod with TV playing in the background.</figcaption>
</figure>

<h1 id="testing-environment">Testing Environment</h1>

<p>We evaluated the performance of the proposed speech processing system on a large speech test set recorded on HomePod in several acoustic conditions:</p>

<ul>
  <li>Music and podcast playback at different levels</li>
  <li>Continuous background noise, including babble  and rain noise</li>
  <li>Directional noises generated by household appliances such as a vacuum cleaner, hairdryer, and microwave</li>
  <li>Interference from external competing sources of speech</li>
</ul>

<p>In these recordings, we varied the locations of HomePod and the test subjects to cover different use cases, for example, in living room or kitchen environments where HomePod was placed against the wall or in the middle of the room.</p>

<p>We investigated the performance of our system in a real setup, where the trigger detection and subsequent voice command recognition jointly affect the user experience. Therefore, we report the objective Siri performance metrics, namely the false reject (FR) and the word error rates (WERs). We chose the tradeoff between false alarm (FA) rates and FRs experimentally to guarantee the best user experience. Because triggered utterances can be different using one processing algorithm or another in different acoustic conditions, the WER numbers are directly influenced by the trigger performance. We discuss this issue below.  In <a href="#audio-examples">Audio Examples</a>, we give some audio examples to demonstrate the subjective quality of the signals enhanced by our algorithms.</p>

<h1 id="system-performance">System Performance</h1>

<p>Figure 3 shows the FRs of our proposed speech enhancement system based on deep learning.  The triggering threshold is the same in all conditions. Mask-based noise reduction is suitable for most acoustic conditions except for the multi-talker and directional noise conditions, which are well handled by our stream selection system. For example in the competing talker case, the absolute FR improvement of the multistream system is 29.0% when compared to mask-based noise reduction, which has no source separation capability, and 30.3% when compared to the output of the baseline DSP system (that includes echo cancellation and dereveberation).</p>

<figure role="presentation">
    <a href="/images/journals/homepod-siri-wild/figure_3_2x.png" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_3_2x.png" width="665px" alt="" />
    </a>
    <figcaption>Figure 3. False rejection rates of “Hey Siri” detector in several acoustic conditions: reverberation, echo, noise and compating talker. ‘<em>+ Baseline DSP</em>’ refers to the baseline DSP. ‘<em>+ Mask-based Noise Reduction</em>’ refers to the baseline DSP and mask-based noise reduction. ‘<em>+ Stream Selection</em>’ refers to the baseline DSP, mask-based noise reduction, and stream selection.</figcaption>
</figure>

<p>The gap between mask-based noise reduction and the multistream system becomes smaller in other acoustic conditions. Overall, there is a clear trend of healthy FR improvement when our mask-based noise reduction and source separation techniques (stream selection) are used.</p>

<p>Figure 4 shows the WERs achieved by combining the multichannel signal processing based on deep learning with the speech recognizer that we adapted on different live data (some of it processed with our online multichannel signal processing).  The blue portion of the bar represents the error rate of the triggered utterances, and the green portion represents the error rate due to falsely rejected utterances (missed utterances). Note that different numbers of words are used for evaluation in the blue portion of the bars since the corresponding number of false rejections are significantly different for each case.</p>

<figure role="presentation">
    <a href="/images/journals/homepod-siri-wild/figure_4_2x.png" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_4_2x.png" width="665px" alt="" />
    </a>
    <figcaption>Figure 4. Word error rates in the same acoustic conditions as Figure 3. ‘<em>+ Baseline DSP</em>’ refers to the baseline DSP. ‘<em>+ Mask-based NR</em>’ refers to the baseline DSP and mask-based noise reduction. ‘<em>+ Stream Selection</em>’ refers to the baseline DSP, mask-based noise reduction, and stream selection.</figcaption>
</figure>

<p>It is obvious that the optimal integration of our speech processing technologies substantially improves the overall WERs across conditions. More specifically, the WER relative improvements are about 40%, 90%, 74%, and 61% in the four investigated acoustic conditions of  reverberant speech only, playback, loud background noise, and competing talker, respectively.</p>

<p>These results also indicate that across most conditions, the WERs on the triggered utterances (blue bar) achieved by mask-based noise reduction and the multistream system are very similar, except for the competing talker and noise cases.  As illustrated by the FR rates in Figure 3, our signal processing algorithms can have significantly different impacts on the voice trigger detection and stream selection. Different utterances can be triggered using one algorithm or another, and these utterances have different numbers of words. This clearly impacts the final WERs, and direct head-to-head comparisons of the different methods might not be straightforward.</p>

<p>The main conclusion that we can draw from Figure 4 is that in addition to the great improvement in FRs using the multistream system demonstrated in Figure 3, our deep learning–based signal processing significantly reduces the word error rates. This improvement allows the user to interact easily with HomePod even in the presence of loud playback and external acoustic distortions like reverberation, noise, and competing talker.</p>

<p>We implemented our online multichannel signal processing system using Apple’s Accelerate Framework for vector and matrix math and neural network inference, and we profiled the system on a single core of an Apple A8 chip. Our proposed speech enhancement system consumes less than 15% of a single core of an A8 chip running at 1.4 GHz.</p>

<p>You can listen to the following audio examples that showcase the enhancement effects of our processing in presence of reverberation with quiet background, additive noise generated by a dishwasher, playback music, and interfering talkers.  The respective spectrograms are shown in Figures 5, 6, 7, and 8.  From the subjective listening and visual inspection of each of these examples, you should be able to hear that the acoustic distortions are significantly reduced, which greatly facilitates the speech recognition task across conditions.</p>

<h1 id="audio-examples">Audio Examples</h1>

<figure role="presentation">
    <a href="/images/journals/homepod-siri-wild/figure_5_top_2x.jpg" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_5_top_2x.jpg" width="665px" alt="" />
    </a>
    <a href="/images/journals/homepod-siri-wild/figure_5_bottom_2x.jpg" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_5_bottom_2x.jpg" width="665px" alt="" />
    </a>
    <figcaption>Figure 5. Siri voice command recorded in presence of reverberation: <br />
        <a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link="">
            <audio><source src="/images/journals/homepod-siri-wild/figure_5_top_audio.mp3" type="audio/mpeg" /></audio>
        (top) microphone signal</a><br />
        <a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link="">
            <audio><source src="/images/journals/homepod-siri-wild/figure_5_bottom_audio.mp3" type="audio/mpeg" /></audio>
        (bottom) dereverberated signal</a>
    </figcaption>
</figure>

<figure role="presentation">
    <a href="/images/journals/homepod-siri-wild/figure_6_top_2x.jpg" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_6_top_2x.jpg" width="665px" alt="" />
    </a>
    <a href="/images/journals/homepod-siri-wild/figure_6_bottom_2x.jpg" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_6_bottom_2x.jpg" width="665px" alt="" />
    </a>
    <figcaption>Figure 6. Siri voice command in presence of background noise generated by a nearby dishwasher: <br />
        <a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link="">
            <audio><source src="/images/journals/homepod-siri-wild/figure_6_top_audio.mp3" type="audio/mpeg" /></audio>
        (top) microphone signal</a><br />
        <a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link="">
            <audio><source src="/images/journals/homepod-siri-wild/figure_6_bottom_audio.mp3" type="audio/mpeg" /></audio>
        (bottom) signal enhanced by our mask-based noise reduction</a>
    </figcaption>
</figure>

<figure role="presentation">
    <a href="/images/journals/homepod-siri-wild/figure_7_top_2x.jpg" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_7_top_2x.jpg" width="665px" alt="" />
    </a>
    <a href="/images/journals/homepod-siri-wild/figure_7_middle_2x.jpg" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_7_middle_2x.jpg" width="665px" alt="" />
    </a>
    <a href="/images/journals/homepod-siri-wild/figure_7_bottom_2x.jpg" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_7_bottom_2x.jpg" width="665px" alt="" />
    </a>
    <figcaption>Figure 7. Siri voice command recorded in presence of loud playback music: <br />
        <a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link="">
            <audio><source src="/images/journals/homepod-siri-wild/figure_7_top_audio.mp3" type="audio/mpeg" /></audio>
        (top) microphone signal</a><br />
        <a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link="">
            <audio><source src="/images/journals/homepod-siri-wild/figure_7_middle_audio.mp3" type="audio/mpeg" /></audio>
        (middle) output of MCEC</a><br />
        <a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link="">
            <audio><source src="/images/journals/homepod-siri-wild/figure_7_bottom_audio.mp3" type="audio/mpeg" /></audio>
        (bottom) signal enhanced by our mask-based echo suppression</a>
    </figcaption>
</figure>

<figure role="presentation">
    <a href="/images/journals/homepod-siri-wild/figure_8_top_2x.jpg" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_8_top_2x.jpg" width="665px" alt="" />
    </a>
    <a href="/images/journals/homepod-siri-wild/figure_8_bottom_2x.jpg" target="_blank">
     <img src="/images/journals/homepod-siri-wild/figure_8_bottom_2x.jpg" width="665px" alt="" />
    </a>
    <figcaption>Figure 8. Siri voice command recorded in presence of interference from other talkers:<br />
        <a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link="">
            <audio><source src="/images/journals/homepod-siri-wild/figure_8_top_audio.mp3" type="audio/mpeg" /></audio>
        (top) microphone signal</a><br />
        <a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link="">
            <audio><source src="/images/journals/homepod-siri-wild/figure_8_bottom_audio.mp3" type="audio/mpeg" /></audio>
        (bottom) extracted target speech</a>
    </figcaption>
</figure>

<h1 id="references">References</h1>

<p><a name="1">[1]</a> K. Kinoshita, M. Delcroix, T. Yoshioka, T. Nakatani, A. Sehr, W. Kellermann, and R. Maas. <a href="https://ieeexplore.ieee.org/document/6701894"><strong>The REVERB challenge: A common evaluation framework for dereverberation and recognition of reverberant speech</strong></a>, <em>in Proc. IEEE WASPAA</em>, 2013.</p>

<p><a name="2">[2]</a> <a href="http://spandh.dcs.shef.ac.uk/chime_challenge/chime2016/"><strong>The 4th CHiME Speech Separation and Recognition Challenge</strong></a>, 2016.</p>

<p><a name="3">[3]</a> H. Erdogan, J.R. Hershey, S. Watanabe, M. Mandel, and J. Le Roux. <a href="https://www.isca-speech.org/archive/Interspeech_2016/pdfs/0552.PDF"><strong>Improved MVDR beamforming using single-channel mask prediction networks</strong></a>, <em>in Proc. ISCA Interspeech</em>, 2016.</p>

<p><a name="4">[4]</a> M.S. Pedersen, J. Larsen, U. Kjems, and L.C. Parra. <a href="http://www2.imm.dtu.dk/pubdb/views/edoc_download.php/4924/pdf/imm4924.pdf"><strong>A survey of convolutive blind source separation methods</strong></a>, <em>Multichannel Speech Processing Handbook</em>, 2007.</p>

<p><a name="5">[5]</a> J.R. Hershey, Z. Chen, J. Le Roux, and S. Watanabe. <a href="https://ieeexplore.ieee.org/document/7471631"><strong>Deep clustering: discriminative embeddings for segmentation and separation</strong></a>, <em>in Proc. IEEE ICASSP</em>, 2016.</p>

<p><a name="6">[6]</a> D. Yu, M. Kolbæk, Z.-H. Tan, and J. Jensen. <a href="https://ieeexplore.ieee.org/document/7952154"><strong>Permutation invariant training of deep models for speaker-independent multi-talker speech separation</strong></a>, <em>in Proc. IEEE ICASSP</em>, 2017.</p>

<p><a name="7">[7]</a> T. Hori, S. Araki, T. Yoshioka, M. Fujimoto, S. Watanabe, T. Oba, A. Ogawa, K. Otsuka, D. Mikami, K. Kinoshita, T. Nakatani, A. Nakamura, and J. Yamato. <a href="https://ieeexplore.ieee.org/document/5983476"><strong>Low-latency real-time meeting recognition and understanding using distant microphones and omni-directional camera</strong></a>, <em>IEEE Transactions on Audio, Speech and Language Processing</em>, vol. 20, no. 2, pp. 499–513, 2012.</p>

<p><a name="8">[8]</a> D.A. Bendersky, J.W. Stokes, and H.S. Malvar. <a href="https://ieeexplore.ieee.org/document/4517596"><strong>Nonlinear residual acoustic echo suppression for high levels of harmonic distortion</strong></a>, <em>In Proc. IEEE ICASSP</em>, 2008.</p>

<p><a name="9">[9]</a> M.M. Sondhi, D.R. Morgan, and J.L. Hall. <a href="https://ieeexplore.ieee.org/document/404129"><strong>Stereophonic acoustic echo cancellation-an overview of the fundamental problem</strong></a>, <em>IEEE Signal Processing Letters</em>, vol. 2, no. 8, pp. 148–151, 1995.</p>

<p><a name="10">[10]</a> A. Schwartz, C. Hofmann, and W. Kellermann. <a href="https://ieeexplore.ieee.org/document/6701825 "><strong>Spectral feature-based nonlinear residual echo suppression</strong></a>, <em>in Proc. IEEE WASPAA</em>, 2013.</p>

<p><a name="11">[11]</a> C. M. Lee, J. W. Shin, and N. S. Kim. <a href="https://www.isca-speech.org/archive/interspeech_2015/papers/i15_1775.pdf "><strong>DNN-based residual echo suppressor</strong></a>, <em>in Proc. ISCA Interspeech</em>, 2015.</p>

<p><a name="12">[12]</a> T. Yoshioka, A. Sehr, M. Delcroix, K. Kinoshita, R. Maas, T. Nakatani, and W. Kellermann. <a href="https://ieeexplore.ieee.org/document/6296524"><strong>Making machines understand us in reverberant rooms: robustness against reverberation for automatic speech recognition</strong></a>, <em>IEEE Signal Processing Magazine</em>, vol. 29, no. 6, pp. 114–126, 2012.</p>

<p><a name="13">[13]</a> A. Jukić, T. van Waterschoot, T.  Gerkmann, and S. Doclo. <a href="https://ieeexplore.ieee.org/document/7336927/"><strong>Group sparsity for MIMO speech dereverberation</strong></a>, <em>in Proc. IEEE WASPAA</em>, 2015.</p>

<p><a name="14">[14]</a> M. Souden, S. Araki, K. Kinoshita, T. Nakatani, and H. Sawada. <a href="https://ieeexplore.ieee.org/document/6516079"><strong>A multichannel MMSE-based framework for speech source separation and noise reduction</strong></a>, <em>IEEE Transactions on Audio, Speech, and Language Processing</em>, vol. 21, no. 9, pp. 1913–1928, 2013.</p>

<p><a name="15">[15]</a>  M. Souden, J. Chen, J. Benesty, and S. Affes. <a href="https://ieeexplore.ieee.org/document/5719158/ "><strong>An integrated solution for online multichannel noise tracking and reduction</strong></a>, <em>IEEE Transactions on Audio, Speech, and Language Processing</em>, vol. 19, no. 7, pp. 2159–2169, 2011.</p>

<p><a name="16">[16]</a> Siri Team. <a href="https://machinelearning.apple.com/2017/10/01/hey-siri.html "><strong>Hey Siri: An On-device DNN-powered Voice Trigger for Apple’s Personal Assistant</strong></a>, <em>Apple Machine learning Journal</em>, vol. 1, no. 6, 2017.</p>

							</div>
						</div>
					</div>
				</div>
			</section>

			<section class="section section-prefooter theme-dark">
	<div class="section-content">
		<div class="row">
			<div class="column large-4 medium-12">
				<div class="text-center">
					<h2 class="prefooter-title">Contact us</h2>
					<p><a href="mailto:machine-learning@apple.com">Send questions or feedback<span class="visuallyhidden"> via email</span><span class="more"></span></a></p>
				</div>
			</div>
			<div class="column large-4 medium-12">
				<div class="text-center">
					<h2 class="prefooter-title">Jobs at Apple</h2>
					<p><a href="https://www.apple.com/jobs/">Apply now<span class="visuallyhidden"> for a career at Apple</span><span class="more"></span></a></p>
				</div>
			</div>
			<div class="column large-4 medium-12">
				<div class="text-center">
					<h2 class="prefooter-title">Tools for innovation</h2>
					<p><a href="https://developer.apple.com/">Apple Developer Program<span class="more"></span></a></p>
				</div>
			</div>
		</div>
	</div>
</section>
		</main>

		<footer class="section section-footer" role="contentinfo">
			<div class="section-content">
				<div class="row">
					<div class="column large-6 small-12">
						<div class="footer-left">
							<a class="logo" href="https://www.apple.com/"></a>
							<span class="copyright typography-caption" aria-hidden="true">Copyright © 2018 Apple Inc. All rights reserved.</span>
							<span class="visuallyhidden">Copyright two thousand seventeen Apple Inc. All rights reserved.</span>
						</div>
					</div>
					<div class="column large-6 small-12">
						<div class="footer-right">
							<a class="typography-caption" href="/feed.xml">Subscribe</a>
							<a class="typography-caption" href="//www.apple.com/privacy/privacy-policy/">Privacy Policy</a>
							<a class="typography-caption" href="//www.apple.com/legal/internet-services/terms/site.html">Terms of Use</a>
							<a class="typography-caption" href="//www.apple.com/legal/">Legal</a>
						</div>
					</div>
				</div>
			</div>
		</footer>
		<script src="/v/machine_learning_journals/a/built/scripts/main.built.js" type="text/javascript" charset="utf-8"></script>
	</body>
</html>
