<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-US" lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js">
	<head>
		<meta http-equiv="X-UA-Compatible" content="IE=8; IE=9" />
		<meta charset="utf-8">
		<meta name="robots" content="noodp">
		<link rel="canonical" href="http://www.apple.com/">
		<meta name="viewport" content="width=device-width, initial-scale=1" />
		<meta name="format-detection" content="telephone=no">
		<title>Deep Learning for Siri’s Voice: On-device Deep Mixture Density Networks for Hybrid Unit Selection Synthesis - Apple</title>
		<link rel="stylesheet" href="//www.apple.com/wss/fonts?families=SF+Pro,v1|SF+Pro+Icons,v1|SF+Mono,v1" type="text/css" media="all" />
		<link rel="stylesheet" href="/v/machine_learning_journals/a/built/styles/machine_learning_journals.built.css" />
		<script src="/v/machine_learning_journals/a/built/scripts/head.built.js" type="text/javascript" charset="utf-8"></script>
		<link rel="alternate" type="application/atom+xml" title="Apple Machine Learning Journal" href="/feed.xml" />
	</head>

			<body class="post">
		<nav class="localnav">
			<div class="ln-content">
				<h2 class="ln-title"><a class="img-ln-title-article" href="/">Machine Learning Journal</a></h2>
			</div>
		</nav>

		<main class="main" role="main">
			<section class="section section-journal" data-journal="true">
				<div class="section-content">
					<div class="large-8 large-centered medium-10 small-12">
						<div class="content-wrapper">
							<div class="content-block">
								<h1 class="typography typography-section-headline">Deep Learning for Siri’s Voice: On-device Deep Mixture Density Networks for Hybrid Unit Selection Synthesis</h1>
								<h2></h2>
								<p>
									 Vol. 1, Issue 4 <span class="weight-light">∙</span> 
									August 2017
									<span class="line-break">by Siri Team</span>
								</p>
							</div>

							<hr>

							<div class="journal-content">
								
<p>Siri is a personal assistant that communicates using speech synthesis. Starting in iOS 10 and continuing with new features in iOS 11, we base Siri voices on deep learning. The resulting voices are more natural, smoother, and allow Siri’s personality to shine through. This article presents more details about the deep learning based technology behind Siri’s voice.</p>

<!--more-->

<h1 id="introduction">Introduction</h1>

<p>Speech synthesis—the artificial production of human speech—is widely used for various applications from assistive technology to gaming and entertainment. Recently, combined with speech recognition, speech synthesis has become an integral part of virtual personal assistants, such as Siri.</p>

<p>There are essentially two speech synthesis techniques used in the industry: unit selection <a href="#1">[1]</a> and parametric synthesis <a href="#2">[2]</a>. Unit selection synthesis provides the highest quality given a sufficient amount of high-quality speech recordings <a href="#3">[3]</a>, and thus it is the most widely used speech synthesis technique in commercial products. On the other hand, parametric synthesis provides highly intelligible and fluent speech, but suffers from lower overall quality. Therefore, parametric synthesis is often used when the corpus is small or a low footprint is required. Modern unit selection systems combine some of the benefits of the two approaches, and so are referred to as hybrid systems. Hybrid unit selection methods are similar to classical unit selection techniques, but they use the parametric approach to predict which units should be selected.</p>

<p>Recently, deep learning has gained momentum the field of speech technology, largely surpassing conventional techniques, such as hidden Markov models (HMMs). Parametric synthesis has benefited greatly from deep learning technology. Deep learning has also enabled a completely new approach for speech synthesis called direct waveform modeling (for example using WaveNet <a href="#4">[4]</a>), which has the potential to provide both the high quality of unit selection synthesis and flexibility of parametric synthesis. However, given its extremely high computational cost, it is not yet feasible for a production system.</p>

<p>In order to provide the best possible quality for Siri’s voices across all platforms, Apple is now taking a step forward to utilize deep learning in an on-device hybrid unit selection system.</p>

<h1 id="how-does-speech-synthesis-work">How Does Speech Synthesis Work?</h1>

<p>Building a high-quality text-to-speech (TTS) system for a personal assistant is not an easy task. The first phase is to find a professional voice talent whose voice is both pleasant and intelligible and fits the personality of Siri.  In order to cover some of the vast variety of human speech, we first need to record 10—20 hours of speech in a professional studio. The recording scripts vary from audio books to navigation instructions, and from prompted answers to witty jokes. Typically, this natural speech cannot be used as it is recorded because it is impossible to record all possible utterances the assistant may speak. Thus, unit selection TTS is based on slicing the recorded speech into its elementary components, such as half-phones, and then recombining them according to the input text to create entirely new speech. In practice, selecting appropriate phone segments and joining them together is not easy, because the acoustic characteristics of each phone depend on its neighboring phones and the prosody of speech, which often makes the speech units incompatible with each other. Figure 1 illustrates how speech can be synthesized using a speech database segmented into half-phones.</p>

<figure role="presentation">
	<figcaption>Figure 1. Illustration of unit selection speech synthesis using half-phones. The synthesized utterance "Unit selection synthesis” and its phonetic transcription using half-phones are shown at the top of the figure. The corresponding synthetic waveform and its spectrogram are shown below. The speech segments delimited by the lines are continuous speech segments from the database that may contain one or more half-phones.</figcaption>
    <a href="/images/journals/siri-voices/half-phone-boundaries.png" tabindex="-1" target="_blank">
        <img src="/images/journals/siri-voices/half-phone-boundaries.png" width="600px" alt="A diagram that shows unit selection speech synthesis process using half-phones. The target sentence, unit selection synthesis, is shown at the top of the figure with its phonetic transcription using half phones. The speech signal and its spectrogram are shown below. The continuous speech segments from the database are delimited by lines. Each segment can contain one or more half-phones." />
    </a> 
</figure>

<p>The fundamental problem of unit selection TTS is to find a sequence of units (e.g. half-phones) that satisfy the input text and the predicted target prosody, provided that the units can be joined together without audible glitches. Traditionally, the process consists of two distinctive parts: front-end and back-end (see Figure 2), although in modern systems the boundary can sometimes be ambiguous. The purpose of the front-end is to provide phonetic transcription and prosodic information based on the raw text input. This includes normalizing the raw text which may include numbers, abbreviations, etc., into written out words, assigning phonetic transcriptions to each word, and parsing syntax, syllable, word, stress, and phrasing-related information from text. Note that the front-end is highly language dependent.</p>

<figure role="presentation">
	<figcaption>Figure 2. Text-to-speech synthesis process</figcaption>
    <a href="/images/journals/siri-voices/process-model-database.png" tabindex="-1" target="_blank">
        <img src="/images/journals/siri-voices/process-model-database.png" width="600px" alt="A diagram that shows the four steps for synthesizing speech from text.  The first step analyzes the text. The next step applies a prosody model. The third step chooses speech segments from a unit database. The final step concatenates the segments into a speech waveform." />
    </a> 
</figure>

<p>Using the symbolic linguistic representation created by the text analysis module, the prosody generation module predicts values for acoustic features, such as intonation and duration. These values are used to select appropriate units. The task of unit selection has high complexity, so modern synthesizers use machine learning methods that can learn the correspondence between text and speech and then predict the values of speech features from the feature values of unseen text. This model must be learned at the training stage of a synthesizer using a large amount of text and speech data. The input to the prosody model are the numerical linguistic features, such as, phone identity, phone context, and syllable, word, and phrase-level positional features converted into convenient numerical form. The output of the model is composed of the numerical acoustic features of speech, such as spectrum, fundamental frequency, and phone duration. At synthesis time, the trained statistical model is used to map from the input text features into speech features, which are then used to guide the unit selection backend process where appropriate intonation and duration are crucial.</p>

<p>In contrast to the front-end, the backend is mostly language independent. It consists of unit selection and waveform concatenation parts. When the system is trained, the recorded speech data is segmented into individual speech segments using forced alignment between the recorded speech and the recording script (using speech recognition acoustic models). The segmented speech is then used to create a unit database. The unit database is further augmented with important information, such as the linguistic context and acoustic features of each unit. We refer to this data as the <em>unit index</em>. Using the constructed unit database and the predicted prosodic features that guide the selection process, a Viterbi search is performed in the speech unit space to find the best path of units for synthesis (see Figure 3).</p>

<figure role="presentation">
	<figcaption>Figure 3. Illustration of Viterbi search for finding the best path of units in the lattice. The target half-phones for synthesis are shown at the top of the figure, below which each box corresponds to an individual unit. The best path, as found by Viterbi search, is shown as a line connecting the selected units.</figcaption>
    <a href="/images/journals/siri-voices/viterbi_lattice.png" tabindex="-1" target="_blank">
        <img src="/images/journals/siri-voices/viterbi_lattice.png" width="600px" alt="A diagram that shows the Viterbi search for finding the best path of units in the lattice. The target half-phones for synthesis are shown at the top of the figure, below which each box corresponds to an individual unit. The best path based on the Viterbi search connects the selected units." />
    </a> 
</figure>

<p>The selection is based on two criteria: 1) the units must obey the target prosody and 2) the units should, wherever possible, be concatenated without audible glitches at the unit boundary. These two criteria are called the target and concatenation costs, respectively. The target cost is the difference between the predicted target acoustic features and the acoustic features extracted from each unit (stored in unit index), whereas the concatenation cost is the acoustic difference between consequent units (see Figure 4). The overall cost is calculated as follows:</p>

<div class="mathEl text-center">
<math xmlns="http://www.w3.org/1998/Math/MathML">
<mrow>
	<mi>C</mi>
	<mo>=</mo>
	<msub>
		<mi>w</mi>
		<mi>t</mi>
	</msub>
	<mstyle displaystyle="true">
		<munderover>
			<mo>&#x02211;</mo>
			<mrow>
				<mi>n</mi>
				<mo>=</mo>
				<mn>1</mn>
			</mrow>
			<mi>N</mi>
		</munderover>
	</mstyle>
	<mi>T</mi>
	<mrow>
		<mo form="prefix">(</mo>
		<msub>
			<mi>u</mi>
			<mi>n</mi>
		</msub>
		<mo form="postfix">)</mo>
	</mrow>
	<mo>+</mo>
	<msub>
		<mi>w</mi>
		<mi>c</mi>
	</msub>
	<mstyle displaystyle="true">
		<munderover>
			<mo>&#x02211;</mo>
			<mrow>
				<mi>n</mi>
				<mo>=</mo>
				<mn>1</mn>
			</mrow>
			<mi>N</mi>
		</munderover>
	</mstyle>
	<mi>C</mi>
	<mrow>
		<mo form="prefix">(</mo>
		<msub>
			<mi>u</mi>
			<mi>n</mi>
		</msub>
		<mo>,</mo>
		<msub>
			<mi>u</mi>
			<mrow>
				<mi>n</mi>
				<mo>+</mo>
				<mn>1</mn>
			</mrow>
		</msub>
		<mo form="postfix">)</mo>
	</mrow>
</mrow>
</math>
</div>

<p>where u<sub>n</sub> is the nth unit, N is the number of units, w<sub>t</sub> and w<sub>c</sub> are the target and concatenation cost weights. After determining the optimal sequence of units, the individual unit waveforms are concatenated to create continuous synthetic speech.</p>

<figure role="presentation">
	<figcaption>Figure 4. Illustration of the unit selection method based on target and concatenation costs.</figcaption>
    <a href="/images/journals/siri-voices/unit-selection-example.png" tabindex="-1" target="_blank">
        <img src="/images/journals/siri-voices/unit-selection-example.png" width="490px" alt="A diagram that shows speech waveform segments that are selected and then concatenated into a waveform. It also shows that there is a cost associated with choosing the segments and another cost associated with pasting the segments together." />
    </a> 
</figure>

<h1 id="technology-behind-siris-new-voice">Technology Behind Siri’s New Voice</h1>

<p>HMMs are commonly used as the statistical model for target predictions <a href="#5">[5]</a> <a href="#6">[6]</a> since they directly model the distributions of acoustic parameters, and thus for example the Kullback-Leibler divergence can be easily used to compute the target cost. However, deep learning-based approaches often outperform HMMs in parametric speech synthesis, and we expect the benefits of deep learning to be translated to hybrid unit selection synthesis as well.</p>

<p>The goal of Siri’s TTS system is to train a unified model based on deep learning that can automatically and accurately predict both target and concatenation costs for the units in the database. Thus, instead of HMMs, the approach uses a deep mixture density network (MDN) <a href="#7">[7]</a><a href="#8">[8]</a> to predict the distributions over the feature values. MDNs combine conventional deep neural networks (DNNs) with a Gaussian mixture models (GMM).</p>

<p>A conventional DNN is an artificial neural network with multiple hidden layers of neurons between the input and output layers. A DNN can thus model a complex and nonlinear relationship between input and output features. A DNN is trained by adjusting the weights of the network using backpropagation. In contrast, a GMM models the probability distribution of the output data given the input data using a set of Gaussian distributions, and is typically trained using the expectation maximization (EM) method. MDNs combine the benefits of DNNs and GMMs by using the DNN to model the complex relationship between input and output data, but providing probability distributions as output (see Figure 5).</p>

<figure role="presentation">
	<figcaption>Figure 5. Deep mixture density network used for modeling both the means and variances of the speech features used for guiding unit selection synthesis.</figcaption>
    <a href="/images/journals/siri-voices/mdn.png" tabindex="-1" target="_blank">
        <img src="/images/journals/siri-voices/mdn.png" width="600px" alt="A diagram that shows a neural network whose inputs are linguistics features and whose outputs are acoustic means and variances. In between are layers of a deep neural network." />
    </a> 
</figure>

<p>For Siri, we use an MDN-based unified target and concatenation model that can predict the distributions of both the target features of speech (spectrum, pitch, and duration) and the concatenation cost between the units to guide the unit search. Since the output of the MDN is in the form of Gaussian probability distributions, we can use the likelihood as a cost function for target and concatenation costs:</p>

<div class="mathEl text-center">
<math xmlns="http://www.w3.org/1998/Math/MathML">
<mrow>
	<mi>&#x02112;</mi>
	<mrow>
		<mo rspace="0.3em" lspace="0em" stretchy="true" fence="true" form="prefix">(</mo>
		<mi>x</mi>
		<mo>|</mo>
		<mi>&#x003BC;</mi>
		<mo>,</mo>
		<mi>&#x003C3;</mi>
		<mo rspace="0em" lspace="0.3em" stretchy="true" fence="true" form="postfix">)</mo>
	</mrow>
	<mo>=</mo>
	<mstyle displaystyle="true">
		<munder>
			<mo>&#x0220F;</mo>
			<mi>i</mi>
		</munder>
	</mstyle>
	<mfrac linethickness="1">
		<mn>1</mn>
		<mrow>
			<msqrt>
				<mrow>
					<mn>2</mn>
					<mi>&#x003C0;</mi>
					<msup>
						<mi>&#x003C3;</mi>
						<mn>2</mn>
					</msup>
				</mrow>
			</msqrt>
		</mrow>
	</mfrac>
	<mi>exp</mi>
	<mrow>
		<mo rspace="0.3em" lspace="0em" stretchy="true" fence="true" form="prefix">{</mo>
		<mfrac linethickness="1">
			<mrow>
				<msup>
					<mrow>
						<mo form="prefix">(</mo>
						<msub>
							<mi>x</mi>
							<mi>i</mi>
						</msub>
						<mo>-</mo>
						<msub>
							<mi>&#x003BC;</mi>
							<mi>i</mi>
						</msub>
						<mo form="postfix">)</mo>
					</mrow>
					<mn>2</mn>
				</msup>
			</mrow>
			<mrow>
				<mn>2</mn>
				<msubsup>
					<mi>&#x003C3;</mi>
					<mi>i</mi>
					<mn>2</mn>
				</msubsup>
			</mrow>
		</mfrac>
		<mo rspace="0em" lspace="0.3em" stretchy="true" fence="true" form="postfix">}</mo>
	</mrow>
</mrow>
</math>
</div>

<p>where x<sub>i</sub> is the ith target feature, μ<sub>i</sub> is the predicted mean, and σ<sub>i</sub><sup>2</sup> is the predicted variance. In the actual cost calculation, it is convenient to use the negative log-likelihood and eliminate the constant terms, which leads to the following simple cost function:</p>

<div class="mathEl text-center">
<math xmlns="http://www.w3.org/1998/Math/MathML">
<mrow>
	<mi>C</mi>
	<mrow>
		<mo rspace="0.3em" lspace="0em" stretchy="true" fence="true" form="prefix">(</mo>
		<mi>x</mi>
		<mo>|</mo>
		<mi>&#x003BC;</mi>
		<mo>,</mo>
		<mi>&#x003C3;</mi>
		<mo rspace="0em" lspace="0.3em" stretchy="true" fence="true" form="postfix">)</mo>
	</mrow>
	<mo>=</mo>
	<mstyle displaystyle="true">
		<munder>
			<mo>&#x02211;</mo>
			<mi>i</mi>
		</munder>
	</mstyle>
	<msub>
		<mi>w</mi>
		<mi>i</mi>
	</msub>
	<mfrac linethickness="1">
		<mrow>
			<msup>
				<mrow>
					<mo form="prefix">(</mo>
					<msub>
						<mi>x</mi>
						<mi>i</mi>
					</msub>
					<mo>-</mo>
					<msub>
						<mi>&#x003BC;</mi>
						<mi>i</mi>
					</msub>
					<mo form="postfix">)</mo>
				</mrow>
				<mn>2</mn>
			</msup>
		</mrow>
		<mrow>
			<mn>2</mn>
			<msubsup>
				<mi>&#x003C3;</mi>
				<mi>i</mi>
				<mn>2</mn>
			</msubsup>
		</mrow>
	</mfrac>
</mrow>
</math>
</div>

<p>where w<sub>i</sub> are the feature weights.</p>

<p>The benefit of this approach becomes more clear when we consider the nature of speech. Sometimes the speech features, such as formants, are rather stable and evolve slowly, such as in the case of vowels. Elsewhere, speech can change quite rapidly, such as in transitions between voiced and unvoiced speech sounds. To take this variability into account, the model needs to be able adjust its parameters according to the aforementioned variability. The deep MDN does this using the variances embedded in the model. Since the predicted variances are context-dependent, we can see that they act as automatic context-dependent weights for the costs. This is important for improving the synthesis quality as we want to calculate the target and concatenation costs specific to the current context. The overall cost is a weighted sum of target and concatenation costs:</p>

<div class="mathEl text-center">
<math xmlns="http://www.w3.org/1998/Math/MathML">
<mrow>
	<msub>
		<mi>C</mi>
		<mrow>
			<mstyle mathvariant="normal">
				<mi>t</mi>
				<mi>o</mi>
				<mi>t</mi>
				<mi>a</mi>
				<mi>l</mi>
			</mstyle>
		</mrow>
	</msub>
	<mrow>
		<mo rspace="0.3em" lspace="0em" stretchy="true" fence="true" form="prefix">(</mo>
		<mi>x</mi>
		<mo>|</mo>
		<mi>&#x003BC;</mi>
		<mo>,</mo>
		<mi>&#x003C3;</mi>
		<mo rspace="0em" lspace="0.3em" stretchy="true" fence="true" form="postfix">)</mo>
	</mrow>
	<mo>=</mo>
	<msub>
		<mi>w</mi>
		<mi>t</mi>
	</msub>
	<mstyle displaystyle="true">
		<munder>
			<mo>&#x02211;</mo>
			<mi>i</mi>
		</munder>
	</mstyle>
	<msub>
		<mi>w</mi>
		<mi>i</mi>
	</msub>
	<mfrac linethickness="1">
		<mrow>
			<msup>
				<mrow>
					<mo form="prefix">(</mo>
					<msub>
						<mi>x</mi>
						<mi>i</mi>
					</msub>
					<mo>-</mo>
					<msub>
						<mi>&#x003BC;</mi>
						<mi>i</mi>
					</msub>
					<mo form="postfix">)</mo>
				</mrow>
				<mn>2</mn>
			</msup>
		</mrow>
		<mrow>
			<mn>2</mn>
			<msubsup>
				<mi>&#x003C3;</mi>
				<mi>i</mi>
				<mn>2</mn>
			</msubsup>
		</mrow>
	</mfrac>
	<mo>+</mo>
	<msub>
		<mi>w</mi>
		<mi>c</mi>
	</msub>
	<mstyle displaystyle="true">
		<munder>
			<mo>&#x02211;</mo>
			<mi>j</mi>
		</munder>
	</mstyle>
	<msub>
		<mi>w</mi>
		<mi>j</mi>
	</msub>
	<mfrac linethickness="1">
		<mrow>
			<msup>
				<mrow>
					<mo form="prefix">(</mo>
					<msub>
						<mi>x</mi>
						<mi>j</mi>
					</msub>
					<mo>-</mo>
					<msub>
						<mi>&#x003BC;</mi>
						<mi>j</mi>
					</msub>
					<mo form="postfix">)</mo>
				</mrow>
				<mn>2</mn>
			</msup>
		</mrow>
		<mrow>
			<mn>2</mn>
			<msubsup>
				<mi>&#x003C3;</mi>
				<mi>j</mi>
				<mn>2</mn>
			</msubsup>
		</mrow>
	</mfrac>
</mrow>
</math>
</div>

<p>where w<sub>t</sub> and w<sub>c</sub> are the target and concatenation cost weights. In this final formula, the target cost aims to ensure that prosody is appropriately reproduced in the synthesized speech (intonation and duration), and the concatenation cost ensures both fluent prosody and smooth concatenation.</p>

<p>After scoring the units based on the total cost using the deep MDN, we perform a traditional Viterbi search to find the best path of units. Then, the units are concatenated using the waveform similarity overlap-add (WSOLA) method to find the optimal concatenation time instants to create smooth and continuous synthetic speech.</p>

<h1 id="results">Results</h1>

<p>We built a deep MDN-based hybrid unit selection TTS system for the new Siri voices. The training speech data contains a minimum of 15 hours of high-quality speech recordings sampled at 48 kHz. We segmented the speech into half-phones using forced alignment, i.e., automatic speech recognition to align the input phone sequence with acoustic features extracted from the speech signal. This segmentation process results in around 1–2 million half-phone units, depending on the amount of recorded speech.</p>

<p>To guide the unit selection process, we trained the unified target and concatenation model using a deep MDN architecture. The input to the deep MDN consists of mostly binary values with some additional continuously-valued features. The features represent information about the quinphone context (2 preceding, current, and 2 succeeding phones); syllable, word, phrase, and sentence level information; and additional prominence and stress features. The output vector consists of the following acoustic features: Mel-frequency cepstral coefficients (MFCCs), delta-MFCCs, fundamental frequency (f0), and delta-f0 (including values both at the beginning and the end of each unit), and the duration of the unit. Since we are using an MDN as an acoustic model, the output also contains the variances of each feature that act as automatic context-dependent weights.</p>

<p>In addition, because the fundamental frequency of speech regions is highly dependent on the utterance as a whole, and in order to create natural and lively prosody in synthesized speech, we employed a recurrent deep MDN to model the f0 features.</p>

<p>The architecture of the trained deep MDN consists of 3 hidden layers with 512 rectified linear units (ReLU) as nonlinearities in each layer. Both input and output features are mean and variance normalized before training. The final unit selection voice consists of the unit database including feature and audio data for each unit, and the trained deep MDN model.</p>

<p>The quality of the new TTS system is superior to the previous Siri system. In an AB pairwise subjective listening tests, listeners clearly preferred the new deep MDN-based voices over the old voices. The results are shown in Figure 6. This better quality can be attributed to multiple improvements in the TTS system, such as deep MDN-based back-end resulting in better selection and concatenation of the units, higher sampling rate (22 kHz vs 48 kHz), and better audio compression.</p>

<figure role="presentation">
	<figcaption>Figure 6. Results of the AB pairwise subjective listening tests. The new voices were rated clearly better in comparison to the old ones.</figcaption>
    <a href="/images/journals/siri-voices/ABX_scores_2x.png" tabindex="-1" target="_blank">
        <img src="/images/journals/siri-voices/ABX_scores_2x.png" width="600px" alt="A chart that shows listeners ratings when comparing the Siri voice in iOS 9 with iOS 10. iOS 10 is a clear winner at least 50 percent of the time for the 13 variants shown, Russian female, US English male, Australian English female, French female, Australian English male, Russian male, US English female, British English, female, British English male, Italian male, Spanish male, Spanish female, and Italian female." />
    </a> 
</figure>

<p>Since the TTS system needs to run on mobile devices, we optimized its runtime performance for speed, memory usage, and footprint by using fast preselection, unit pruning, and parallelization of the calculations.</p>

<h1 id="a-new-voice">A New Voice</h1>

<p>For iOS 11, we chose a new female voice talent with the goal of improving  the naturalness, personality, and expressivity of Siri’s voice. We evaluated hundreds of candidates before choosing the best one. Then, we recorded over 20 hours of speech and built a new TTS voice using the new deep learning based TTS technology. As a result, the new US English Siri voice sounds better than ever. Table 1 contains a few examples of the Siri deep learning -based voices in iOS 11 and 10 compared to a traditional unit selection voice in iOS 9.</p>

<p>For more details on the new Siri text-to-speech system, see our published paper “Siri On-Device Deep Learning-Guided Unit Selection Text-to-Speech System” <a href="#9">[9]</a>.</p>

<p class="table-caption">Table 1. Examples of Siri’s new voice in iOS 11</p>

<div class="table-wrapper">

  <table>
    <thead>
      <tr>
        <th><strong>iOS 9</strong></th>
        <th><strong>iOS 10</strong></th>
        <th><strong>iOS 11</strong></th>
        <th><strong>Phrase</strong></th>
      </tr>
    </thead>
    <tbody>
      <tr>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios9-003.mp3" type="audio/mpeg" /></audio> </a></td>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios10-003.mp3" type="audio/mpeg" /></audio> </a></td>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios11-003.mp3" type="audio/mpeg" /></audio> </a></td>
        <td>“Bruce Frederick Joseph Springsteen born…”</td>
      </tr>
      <tr>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios9-004.mp3" type="audio/mpeg" /></audio> </a></td>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios10-004.mp3" type="audio/mpeg" /></audio> </a></td>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios11-004.mp3" type="audio/mpeg" /></audio> </a></td>
        <td>“Okay, I set up your meeting…”</td>
      </tr>
      <tr>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios9-005.mp3" type="audio/mpeg" /></audio> </a></td>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios10-005.mp3" type="audio/mpeg" /></audio> </a></td>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios11-005.mp3" type="audio/mpeg" /></audio> </a></td>
        <td>“One liter is…..”</td>
      </tr>
      <tr>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios9-nav1.mp3" type="audio/mpeg" /></audio> </a></td>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios10-nav1.mp3" type="audio/mpeg" /></audio> </a></td>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios11-nav1.mp3" type="audio/mpeg" /></audio> </a></td>
        <td>“Continue on Skyview drive…”</td>
      </tr>
      <tr>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios9-nav3.mp3" type="audio/mpeg" /></audio> </a></td>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios10-nav3.mp3" type="audio/mpeg" /></audio> </a></td>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios11-nav3.mp3" type="audio/mpeg" /></audio> </a></td>
        <td>“Take a left on Rocky Ridge Road…”</td>
      </tr>
      <tr>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios9-010.mp3" type="audio/mpeg" /></audio> </a></td>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios10-010.mp3" type="audio/mpeg" /></audio> </a></td>
        <td><a href="#" class="icon icon-before icon-thumbnailplay" data-audio-link=""><audio><source src="/images/journals/siri-voices/ios11-010.mp3" type="audio/mpeg" /></audio> </a></td>
        <td>“Always close the barn door tight.”</td>
      </tr>
    </tbody>
  </table>

</div>

<h1 id="references">References</h1>

<p><a name="1">[1]</a> A. J. Hunt, A. W. Black. <strong>Unit selection in a concatenative speech synthesis system using a large speech database</strong>, <em>ICASSP</em>, 1996.</p>

<p><a name="2">[2]</a> H. Zen, K. Tokuda, A. W. Black. <strong>Statistical parametric speech synthesis</strong>  <em>Speech Communication</em>, Vol. 51, no. 11, pp. 1039-1064, 2009.</p>

<p><a name="4">[3]</a> S. King, <strong>Measuring a decade of progress in Text-to-Speech</strong>,  <em>Loquens</em>, vol. 1, no. 1, 2006.</p>

<p><a name="3">[4]</a> A. van den Oord, S. Dieleman, H. Zen, K. Simonyan, O. Vinyals, A. Graves, N. Kalchbrenner, A. W. Senior, K. Kavukcuoglu. <strong>Wavenet: A generative model for raw audio</strong>,  arXiv preprint arXiv:1609.03499, 2016.</p>

<p><a name="5">[5]</a> Y. Qian, F. K. Soong, Z. J. Yan. <strong>A Unified Trajectory Tiling Approach to High Quality Speech Rendering</strong>,  <em>IEEE Transactions on Audio, Speech, and Language Processingv</em>, Vol. 21, no. 2, pp. 280-290, Feb. 2013.</p>

<p><a name="6">[6]</a> X. Gonzalvo, S. Tazari, C. Chan, M. Becker, A. Gutkin, H. Silen, <strong>Recent Advances in Google Real-time HMM-driven Unit Selection Synthesizer</strong>,  <em>Interspeech</em>, 2016.</p>

<p><a name="7">[7]</a> C. Bishop. <strong>Mixture density networks</strong>,  Tech. Rep. NCRG/94/004, Neural Computing Research Group. Aston University, 1994.</p>

<p><a name="8">[8]</a> H. Zen, A. Senior. <strong>Deep mixture density networks for acoustic modeling in statistical parametric speech synthesis</strong>,  <em>ICASSP</em>, 2014.</p>

<p><a name="9">[9]</a> T. Capes, P. Coles, A. Conkie, L. Golipour, A. Hadjitarkhani, Q. Hu, N. Huddleston, M. Hunt, J. Li, M. Neeracher, K. Prahallad, T. Raitio, R. Rasipuram, G. Townsend, B. Williamson, D. Winarsky, Z. Wu, H. Zhang. <strong>Siri On-Device Deep Learning-Guided Unit Selection Text-to-Speech System</strong>, <em>Interspeech</em>, 2017.</p>


							</div>
						</div>
					</div>
				</div>
			</section>

			<section class="section section-prefooter theme-dark">
	<div class="section-content">
		<div class="row">
			<div class="column large-4 medium-12">
				<div class="text-center">
					<h2 class="prefooter-title">Contact us</h2>
					<p><a href="mailto:machine-learning@apple.com">Send questions or feedback<span class="visuallyhidden"> via email</span><span class="more"></span></a></p>
				</div>
			</div>
			<div class="column large-4 medium-12">
				<div class="text-center">
					<h2 class="prefooter-title">Jobs at Apple</h2>
					<p><a href="https://www.apple.com/jobs/">Apply now<span class="visuallyhidden"> for a career at Apple</span><span class="more"></span></a></p>
				</div>
			</div>
			<div class="column large-4 medium-12">
				<div class="text-center">
					<h2 class="prefooter-title">Tools for innovation</h2>
					<p><a href="https://developer.apple.com/">Apple Developer Program<span class="more"></span></a></p>
				</div>
			</div>
		</div>
	</div>
</section>
		</main>

		<footer class="section section-footer" role="contentinfo">
			<div class="section-content">
				<div class="row">
					<div class="column large-6 small-12">
						<div class="footer-left">
							<a class="logo" href="https://www.apple.com/"></a>
							<span class="copyright typography-caption" aria-hidden="true">Copyright © 2017 Apple Inc. All rights reserved.</span>
							<span class="visuallyhidden">Copyright two thousand seventeen Apple Inc. All rights reserved.</span>
						</div>
					</div>
					<div class="column large-6 small-12">
						<div class="footer-right">
							<a class="typography-caption" href="//www.apple.com/privacy/privacy-policy/">Privacy Policy</a>
							<a class="typography-caption" href="//www.apple.com/legal/internet-services/terms/site.html">Terms of Use</a>
							<a class="typography-caption" href="//www.apple.com/legal/">Legal</a>
						</div>
					</div>
				</div>
			</div>
		</footer>
		<script src="/v/machine_learning_journals/a/built/scripts/main.built.js" type="text/javascript" charset="utf-8"></script>
		<script src="https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.0/MathJax.js?config=TeX-MML-AM_CHTML"></script>
	</body>
</html>
